Slow performance using nginx as reverse proxy (no replies)
Hi, I'm the new one ;-) I use nginx as a reverse proxy in the following configuration: Ubuntu 22.04, nginx 1.18.0, access to two web services on host A and host B, which are accessible via...
View ArticleUnable to start nginx after SSL configuration (no replies)
nginx is configured with ssl module nginx version: nginx/1.14.1 built by gcc 8.2.1 20180905 (Red Hat 8.2.1-3) (GCC) built with OpenSSL 1.1.1 FIPS 11 Sep 2018 (running with OpenSSL 1.1.1k FIPS 25 Mar...
View Articlehtml does not display photo (2 replies)
nginx is running Ok on my Raspberry PI server. In my www directory, I have html and images directories, with html being the root for my website of johnrose.mywire.org. When I double click the...
View ArticleDouble Escaping in $ssl_client_s_dn (no replies)
I have a client certificate which has non English characters in the subject, when I use the attribute $ssl_client_s_dn of ngx_http_ssl_module the value is escaped twice. actual value =...
View Articlereturn 404 not show my custom error_page (no replies)
I hope in the ".xxx.net" site, if the domain name is a specific "a.xxx.net", it will return 404 with my custom 404 page(error_page conf). But according to the following configuration, what I see is...
View ArticleNginx ERR_CONNECTION_RESET (no replies)
Hi, I have a WordPress site on Ubuntu 24.04 with Nginx 1.24.0 as web server software. The site is behind a NetworkSolutions load balancer which handles the SSL cert. I am running into a...
View Articlebackup stays active (no replies)
i have an upstream clause with two servers. one is the primary and the other is the backup. upstream Service { server 127.0.0.1:8106; server 127.0.0.1:8100 backup; } periodically, the primary server...
View ArticleAssistance with Setting Up NGINX Load Balancing for a Website (no replies)
Hello Everyone, I'm having some trouble appropriately establishing NGINX as a load balancer for a web application that I'm working on. I want to split up the traffic equally among three backend servers...
View ArticleNginx does not route traffic to https (no replies)
This is my nginx conf user nginx; worker_processes auto; error_log /var/log/nginx/error.log notice; pid /run/nginx.pid; # Load dynamic modules. See /usr/share/doc/nginx/README.dynamic. include...
View ArticleNginx Load Balancing Redirecting to Host Server (1 reply)
Hi Community, Nginx is new for me. I want to use it as a load balancer for two WordPress websites. I installed Ngnix on a Rhel9 server and created a loadbalancer.conf file in etc/nginx/cond.d/ with the...
View Articlenginx weak cipher disabled but still in use (no replies)
I'm trying to remove DES-CBC3-SHA cipher from nginx config. This is the part of nginx config where !DES is commented out so technically ES-CBC3-SHA should not be used at all. ssl_ciphers...
View ArticleNginx stops processing requests hours after a restart (no replies)
Hi everyone, I am encountering a problem whenever updating my website's SSL certificate and then restarting Nginx (I use nginx -s quit for stopping Nginx). After Nginx is restarted, it continues...
View ArticleUpstream sent "Content-Length" and "Transfer-Encoding" headers at the same...
We are upgrading from Nginx 1.22.0 to Nginx 1.24.0. We have an upstream node server that is sending both "Content-Length" and "Transfer-Encoding" headers in the response which eventually causes the...
View ArticleUnstable connection with tcp stream proxy and proxy_bind (no replies)
Hello, We are using NGINX stream TCP proxy with the proxy_bind transparent directive for IP transparency...
View ArticleNginx Reverse Proxy issue with upstream temporarily disabled (no replies)
I'm trying to configure a reverse proxy for Artifactory Jfrog. Basically I have three containers: Postgres, Artifactory and Nginx. The idea is to proxy the request to Artifactory through Nginx. I'm...
View Article504 Gateway Time-out (no replies)
Hello I just posted a request for help on How to page, but this is a seperate request for a problem. I have intermittent issue with 504 messages on the my site which runs on nginx 1.18.0. See attached...
View Articleupstream prematurely closed connection while reading upstream (no replies)
Hi have a 502 error, when i contact the client give me the error log added in Subject and the 502 error by browser
View ArticleMy nginx config resets automatically from time to time erasing all...
I am a layman in this field. My problem is that my nginx customizations work good for 3 or 4 days then suddenly all the customizations are removed and the configuration is reverted to its previous...
View ArticleCurl upload via nginx reverse proxy gives error (no replies)
When uploading the file using curl command via nginx reverse porxy, nginx returns 404 error. This happens only for some specific package. When by passing nginx this file is getting uploaded. We are...
View Articlecan nginx work as forward proxy for https traffic ? (no replies)
Hi Everyone Good morning. Is possible nginx use to process forward proxy traffic for HTTPS destination ? I am having a requirement which is proxy users are point to nginx and proxy user require access...
View Article